Cyclone Alfred - Brisbane and South-East Queensland

Incident Report for Lookout

Resolved

This incident has been resolved.
Posted Mar 13, 2025 - 16:36 AEST

Update

All our staff are safe. The weather event has now finished.
Posted Mar 13, 2025 - 16:36 AEST

Update

First reports this morning indicate our staff are safe. Some are experiencing power outages, internet outages, minor flooding, or have moved to safer locations. We are grateful for this outcome.

Our platform has continued to remain highly available and supported.

The weather event has not yet finished so we'll keep this incident open to continue providing updates.
Posted Mar 10, 2025 - 11:24 AEST

Monitoring

We have been tracking Cyclone Alfred since last week and have made the decision to activate our business continuity plan. We have designed our business to withstand these kinds of events so Lookout can remain highly available to you.

Our infrastructure is in Sydney, with redundant backups in Melbourne. We do not anticipate any disruption to your instance of Lookout. You can remain focused on your clients and workers.

Our staff are distributed around the country with redundancies across key roles. We have made plans to accomodate staff who are travelling to, or working from the affected area to ensure their safety. We do not anticipate any disruption to inbound support, but will reach out to stakeholders of projects where planned activities may be disrupted.

Should Brisbane and the South-East Queensland region be significantly impacted, we have clear lines of responsibility in place for the ongoing management and performance of our business.

For any support enquiries, please use our official inbound channels:
- success@thelookoutway.com
- https://support.thelookoutway.com/en/

We remain committed to providing highly available service and will continue to keep you informed as the situation evolves in this incident.
Posted Mar 04, 2025 - 13:01 AEST
This incident affected: Platform, Third-party integrations, and Analytics.