Increased issues with sending of digital agreements

Incident Report for Lookout

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 15:50 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 28, 2025 - 15:04 AEST

Identified

The issue has been identified and we are now working to provide a solution to those impacted
Posted Aug 28, 2025 - 14:53 AEST

Investigating

We have identified an issue with digital agreements not being generated and sent by Lookout. We are currently investigating the issue.
Posted Aug 28, 2025 - 12:55 AEST
This incident affected: Third-party integrations.