Delays to email delivery
Incident Report for Lookout
Resolved
This incident has been resolved.
Posted Oct 01, 2024 - 10:34 AEST
Monitoring
Our mail delivery service implemented a fix, and mail delivery has returned to normal. We'll continue to monitor.
Posted Oct 01, 2024 - 09:54 AEST
Identified
We are aware of an issue with our mail delivery service, causing intermittent delays to email notification and report delivery. We're monitoring the situation.
Posted Oct 01, 2024 - 09:38 AEST
This incident affected: Platform.